mercoledì 14 novembre 2012

python 3.3 and virtualenv


As in pep-0405 Python 3 new virtualenv specs are now implemented in Python 3.3.

Install python3.3 and venv it 


Python 3.3 has those bleeding edge venvs, lets try them and bleed!

# please add the source if needed
# it could need a package from experimental

set -e # exit in case of errors 

if grep -vqs "experimental main" ; then
    echo "deb experimental main" | \
    sudo tee -a /etc/apt/sources.list > /dev/null

sudo apt-get install python3.3
pyvenv-3.3 .pyvenv-3.3
. .pyvenv-3.3/bin/activate 

Install pyglet 

# pip install pyglet # if lucky and in the future
# maybe check for something >= 1.2 on
cd pyglet-1.2alpha11
python install

  Install pip

curl -O
I dreamed now for

easy_install pip
but I had to do that uglyness below, I'm missing a prefix probably (I hope!)

mv .pyvenv-3.3/local/lib/python3.3/dist-packages/ .pyvenv-3.3/lib/
easy_install-3.3 pip

Is there something wrong here?

Nessun commento:

Posta un commento